Troubleshooting für Anbindung von SIP-Gateways

Voraussetzungen zur Anbindung

Konfigurieren des XCC

Beim XPhone Call Controller (XCC) handelt es sich um einen Softswitch bzw. einen Medien Controller, der nahtlos in die XPhone Connect Umgebung integriert ist. Auf diesem Softswitch werden SIP-Gateways für den Konferenz- bzw. für den AnyDevice-Dienst eingerichtet. Der XPhone Call Controller wird mit dem XPhone Connect Server installiert. Er kommuniziert in Richtung Telefonanlage über SIP-Trunks sowie mit XPhone Connect via TCP.

Grundsätzlich ist der XCC deaktiviert.

Zunächst muss der XCC aktiviert werden, dazu muss unter Systemeinstellungen > Telefonie & Meetings > Telefonie > SIP der XCC bearbeitet werden:

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Entfernen Sie den Haken bei Deaktiviert, im Standard wird auf localhost und dem Port 8021 der Dienst des XCC gestartet. Die Firewall am Server muss die Verbindung auf den entsprechenden Port freigeben.

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Nachdem die Einstellungen zum XCC gespeichert wurden, wird sich der Status des XCC auf grün stellen. Die Aktivierung des XCC kann einige Minuten in Anspruch nehmen.

Anlegen eines SIP-Gateways

Für die Anbindung an die entsprechende Telefonanlage muss ein neues SIP-Gateway eingerichtet werden. Dazu fügen Sie einen neuen SIP Trunk hinzu:

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In der Bearbeitungsmaske müssen nun die entsprechenden Daten zum SIP-Gateway hinterlegt werden:

Gatewaytyp:

Die entsprechende Telefonanlage muss an dieser Stelle ausgewählt werden. (Beispiel mit einer Siemens HiPath 3000)

Name:

Geben Sie hier einen eindeutigen Namen ein.

Wahlparameter:

Wählen Sie einen Wahlparameter aus.

IP-Adresse des XCC Gateways:

Lokale IP-Adresse des XCC, welche als Ziel IP-Adresse in der Telefonanlage hinterlegt werden muss.

Hinweis

Beachten Sie, dass beim Einsatz der Fax- oder Voicemail-Funktion über XCAPI für den XCC SIP-Trunk entweder eine andere IP-Adresse (die auf der XPhone Connect Server Maschine eingerichtet werden muss) oder ein alternativer Port verwendet werden muss, da auch XCAPI auf Port 5060 arbeitet. Der alternative Port muss auch in der Telefonanlage im SIP-Trunk konfiguriert sein.

Port des XCC Gateways:

Standardport: 5060

  • Listener-Port für die SIP Meldungen von der Telefonanlage. Dieser Port muss auf Seiten der Telefonanlage im SIP-Trunk hinterlegt sein.

Hinweis

Beachten Sie, dass beim Einsatz der Fax- oder Voicemail-Funktion über XCAPI für den XCC SIP-Trunk entweder eine andere IP-Adresse (die auf der XPhone Connect Server Maschine eingerichtet werden muss) oder ein alternativer Port verwendet werden muss, da auch XCAPI auf Port 5060 arbeitet. Der alternative Port muss auch in der Telefonanlage im SIP-Trunk konfiguriert sein.

IP-Adresse der Telefonanlage:

Die IP-Adresse der Telefonanlage, welche den SIP-Trunk zur Verfügung stellt.

Port der Telefonanlage:

Standardport: 5060

  • Listener-Port der Telefonanlage für den eingerichteten SIP-Trunk.

Protokoll:

Welches Übertragungsprotokoll soll verwendet werden (UDP oder TCP)

  • CLIP No Screeening:

    In welchem SIP Header soll die CLI (Calling Line Identification) übermittelt werden, so dass die Telefonanlage den entsprechenden Wert auslesen bzw. verarbeiten kann.

AnyDevice:
Damit alle Benutzer eine einheitliche Rufnummer für die Umleitung zu AnyDevice verwenden können, muss die verwendete Telefonanlage die Übermittlung der Rufnummer des umleitenden Benutzers im SIP-Diversion-Header oder im History-Header unterstützen. Aus diesem Header wird der ursprünglich angerufene Teilnehmer ermittelt. Aktivieren Sie dafür diese Checkbox: „Einheitliche Rufnummer …“.
Rufnummer für die Umleitung:
Tragen Sie die Rufnummer für die Umleitung ein, diese Rufnummer muss in der Telefonanlage konfiguriert und fest zum XCC geroutet werden. Aktiviert ein Benutzer später die AnyDevice Funktion an seinem XPhone Connect Connect Client, so wird seine Nebenstelle automatisch zu der hier eingetragenen Rufnummer umgeleitet.
Erweiterten Einstellungen:
Für das XCC-Gateway kann die Rufnummer für den virtuellen Teilnehmer als Rufumleitungsziel hinterlegt werden: XccGlobalVirtualFollowMeUserNo = 999
Für den virtuellen Teilnehmer, z.B. 999, kann in der Telefonanlage ein Name, z.B. „Follow-Me“ hinterlegt werden, so dass im Display des Endgeräts dieser Name bei Umleitungen angezeigt wird. Der virtuelle Teilnehmer muss auf die eigentliche AnyDevice-Nummer umgeleitet werden.
Konferenz:
Hier können Sie, durch Aktivierung der Checkbox, Einwahlkonferenzen erlauben.
Geben Sie eine von Extern und Intern wählbare Nebenstellennummer ein und weisen Sie diese einer Sprache fest zu. Bitte beachten Sie die weiteren, notwendigen Einstellungen zum Konferenzserver im Punkt Einrichtung des Konferenzservers.

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Nachdem die Einstellungen gespeichert wurden, wird das XCC Gateway automatisch gestartet und der Status sollte anschließend grün werden:

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Einrichtung des Konferenzservers

In der Konfigurationsoberfläche des SIP-Gateways wurden bereits die Rufnummern für den Konferenzdienst hinterlegt. Die Rufnummern wurden den entsprechenden Sprachen zugewiesen. Damit der Konferenzserver in vollem Umfang zur Verfügung steht, werden noch weitere Konfigurationen benötigt.

Aktivieren des Konferenzdienstes

Navigieren Sie zu Systemeinstellungen > Telefonie & Meetings > Meetings. Es muss der Konferenzdienst aktiviert werden:

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Konferenzdienst für den jeweiligen Standort aktivieren

In der Benutzerverwaltung muss am jeweiligen Standort der Konferenzdienst aktiviert werden. Dazu müssen die Einstellungen im Punkt Telefonie angepasst werden:

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Aktivieren des Loggings

Für eine Fehleranalyse werden immer die Entsprechenden Logfiles benötigt. Ein wesentlicher Vorteil ist die Netzwerkkommunikation lesen zu können. Für den Mitschnitt des Netzwerktraffics auf der Netzwerkkarte wird der Npcap-Treiber benötigt. Dieser ist im Installationsverzeichnis des XPhone Connect Servers unter Tools zu finden.

Das entsprechende Logging kann über die Administration im XPhone Connect Server gestartet werden. Unter Systemeinstellungen > Logging > Telefonie-Gateways können die entsprechenden Log-Levels gesetzt werden.

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Sobald die Einstellungen zum Log-Level gespeichert wurden, werden die Logfiles in den angegebenen Dateipfad geschrieben.

Informationen aus dem XPhone Call Controller Log

Aus dem Logfile des XPhone Call Controller können zum Beispiel folgende Informationen entnommen werden:

  • gesetzte AnyDevice Ziele der einzelnen User.

  • Follow-Me bei eingehenden Rufen.

  • Rufaufbau bei ausgehenden Rufen.

  • Status des XCC Dienstes.

Informationen aus dem XCC Gateway Log

Aus dem Logfile des XCC Gateways können zum Beispiel folgende Informationen entnommen werden:

  • Status der AnyDevice Leitungen.

  • Erstellen von Netzwerktraces mit Hilfe von Npcap.

  • Status des XCC Gateways.

Überprüfung der Funktion

XPhone Call Controller Status

Über die Diagnose lässt sich der Status des XCC auslesen. Des Weiteren können die Logfiles eine Aussage zum XCC selbst geben.

Für die Diagnose des XCC muss unter Systemeinstellungen > Telefonie & Meetings > Telefonie > SIP der XPhone Call Controller markiert und die Diagnose ausgewählt werden:

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Im nächsten Fenster kann der Status des XPhone Call Controllers geprüft werden:

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SIP-Gateway Status

Über die Diagnose lässt sich der Status des SIP-Gateways auslesen. Des Weiteren können die Logfiles eine Aussage zum SIP-Gateway geben.

Für die Diagnose des XCC muss unter Systemeinstellungen > Telefonie & Meetings > Telefonie > SIP das entsprechende SIP-Gateway markiert und die Diagnose ausgewählt werden:

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Im Diagnose-Fenster kann der Status des Gateways überprüft werden. Ein SIP-Gateway wird den grünen, verbunden Status, erhalten, wenn die Telefonanlage, bzw. der Remote-Trunk, den SIP-OPTION-Request, welcher vom XCC geschickt wird, mit einem SIP-200-OK beantwortet.

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Hinweis

Werden Wahlparameter des SIP-Gateways geändert, so muss, zur Aktivierung des neuen Wahlparameters, das SIP-Gateway neugestartet werden. Dazu dient der Button Neustart der Verbindung zum SIP-Trunk.

Troubleshooting zum SIP-Gateway Status

Testumgebung:

Einrichten eines weiteren SIP-Gateways Log_Test mit einer Gateway IP-Adresse (Telefonanlage), welche nicht erreichbar ist.

Zur Analyse gibt es mehrere Vorgehensweisen.

Überprüfung der Logfiles des XCC Gateways

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Sofern der Npcap installiert wurde, ist es sehr hilfreich die Netzwerkausgabe zu betrachten (WPCAP):

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Es ist zu erkennen, dass nur der SIP-Request zur IP Adresse der Telefonanlage (192.168.110.220) gesendet wird. Es fehlt die Antwort der Telefonanlage.

Im Gegenteil zum funktionierenden XCC-Gateway:

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Die Lesbarkeit eines Npcap-Files wird durch den Einsatz des Wiresharks wesentlich vereinfacht. Das Npcap-File kann während des Debug-Vorgangs mit dem Wireshark geöffnet werden, jedoch werden neue Meldungen nicht angezeigt. Das File muss dazu erneut geöffnet werden. Die Logfiles findet man im XPhone Connect Server Verzeichnis unter dem Pfad <XPhone Connect Server>\Telephony\Log\.

Das Beispiel zeigt die Anbindung in einem 192.168.0.0/16 Netzwerk:

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Überprüfung der Logfiles des XPhone Call Controllers

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In beiden Fällen muss die Verbindung zwischen dem SIP-Gateway und der Telefonanlage geprüft werden:

  • Korrekte Eingabe der IP-Adressen.

  • Ports für die SIP Kommunikation.

  • Überprüfung des IP-Routings zwischen XPhone Connect Server und Telefonanlage.

  • Überprüfung der Firewall zwischen XPhone Connect Server und Telefonanlage.

Überprüfung des Call Routings am SIP-Gateway

Einrichtung zum Test eines Inbound Calls

Damit der Inbound Call getestet werden kann, muss das SIP-Gateway angebunden sein. Des Weiteren muss die AnyDevice Rufnummer in der Telefonanlage eingerichtet und in den Standorteinstellungen muss AnyDevice für die User freigegeben sein. Der Testuser benötigt zudem eine konfigurierte AnyDevice Leitung.

Einrichtung am Connect Client

Im Connect Client muss in das AnyDevice Ziel über die Geräteverwaltung definiert und anschließend aktiviert werden.

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Die Einrichtung des AnyDevice Ziels ist abgeschlossen, die Testanrufe auf die Festnetzrufnummer des Users können gestartet werden.

Überprüfung der Einrichtung im Logging

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Überprüfung des Loggings auf den eingehenden Ruf

Der eingehende Ruf kann in den Logfiles des XPhone Call Controllers geprüft werden. Hier werden die Ausgaben des Logs im Klartext wiedergegeben:

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Testszenario:

  • Der User mit NST 195 hat mit aktiviertem Follow-Me das AnyDevice Ziel 187 hinterlegt.

  • AnyDevice Rufumleitungsziel: 2644

  • Inbound Call von NST 254 zu 195 mit Weiterleitung an das AnyDevice Ziel 187:

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Troubleshooting für das Routing des Inbound Calls

Fehlerhafte Eingabe des AnyDevice Ziels:

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In diesem Fall wurde als AnyDevice Rufnummer die 00171187187187 eingegeben. Durch die Wahlparameter wird die Amtsholung automatisch hinzugefügt, somit wird versucht ein Ruf zu der folgenden Nummer aufzubauen 000171187187187. Diese Nummer kann nicht angewählt werden, somit wird dieser Ruf mit der Meldung Originator_Cancel (Originator = Telefonanlage) beendet.

Im Log ist kein Ruf zu sehen

Hierzu muss das Routing in der Telefonanlage überprüft werden. Am Apparat wird die Rufumleitung zur AnyDevice Rufnummer gesetzt. Demnach muss in der Telefonanlage das Routing angepasst werden, dass die Weiterleitung auf den Trunk zum SIP-Gateway greift.

Des Weiteren kann die Firewall benötigte Ports blocken. Daher muss der eingestellte Port für die SIP Kommunikation, als auch die RTP Ports (30000 – 31000) für das Medienstreaming, freigegeben sein.

Überprüfung / Anpassung des Rufnummernformats

Wo ist die Rufnummer im Logfile zu sehen?

Im XCC Logfile können die Rufnummern bei outbound/ inbound Calls analysiert werden.

Beispiel:

  • Der User mit NST 195 hat mit aktiviertem Follow-Me das AnyDevice Ziel 187 hinterlegt.

  • AnyDevice Rufumleitungsziel: 2644

  • Inbound Call von NST 254 zu 195 mit Weiterleitung an das AnyDevice Ziel 187:

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Erläuterung:

  1. Setzen des AnyDevice Ziels mit aktiviertem Follow-Me

  2. Eingehender Ruf von +4989840798254, weitergeleitet an 2644 (Rufumleitungsnummer von AnyDevice)

  3. Diversion Header (Rufnummer, welche umgeleitet wurde) und der erwartete Wert

  4. AnyDevice Ziel

  5. Bestätigung, dass es am AnyDevice klingelt

Wie kann die Rufnummernkonvertierung angepasst werden?

In den meisten Fällen kann empfohlen werden, dass für ein SIP-Gateway neue Wahlparameter und nicht die vom CTI Gateway verwendet werden.

Alles Weitere wird über die Wahlparameter des SIP-Gateways gemacht, wie es bereits für CTI im Einsatz ist. Der XCC hat seinen eigenen Nummernkonverter, dieser verwendet aber die XPhone Connect Server Wahlparameter-Einstellungen des entsprechenden Gateways.

Einzelfälle müssen immer gesondert betrachtet werden. Dazu werden die entsprechenden Logfiles des XCC und XCC-Gateways, sowie eine genaue Beschreibung zum Test benötigt.

DTMF-Analyse und Problembehebung

Problem

Es kann vorkommen, dass trotz korrekter Protokollaushandlung zwischen XCC und PBX über SDP die Outband DTMF-Signale (RTP-Event gemäß RFC 2833) von der PBX falsch übermittelt werden. Die Signale werden dann vom XCC nicht erkannt, auf DTMF-Eingaben erfolgt keine Reaktion.

Ursache

Der SDP-Header enthält nach der Protokollaushandlung den falschen DTMF Payload Type. Der XCC-Standardwert für den DTMF Payload Type ist 98, es kann vorkommen, dass entweder die PBX diesen Payload Type nicht unterstützt oder die RTP-Events mit einem anderen Payload Type sendet.

Lösung

Der Parameter XccDtmfPayloadType erlaubt die manuelle Korrektur des übermittelten Payload Types, die DTMF-Signale werden wieder korrekt erkannt. Dieser Parameter kann in den Erweiterte Einstellungen des SIP-Gateways gesetzt werden.

Den dort einzusetzenden Payload Type ermitteln Sie wie folgt (s. auch Beispiel weiter unten):

  1. Rufrichtung ermitteln (Inbound oder Outbound)

  2. Sender der DTMF-Signale ermitteln (AnyDevice oder Konversationspartner)

  3. Netzwerktrace erstellen und auswerten (Npcap, Wireshark)

  4. Payload Type in der SIP-Nachricht ermitteln (abhängig von der Rufrichtung im INVITE oder 200 OK)

  5. RTP-Events filtern mit udp.dstport == <Port> && ip.dst == <IP-Adresse> && rtpevent

  6. Payload Type im RTP-Event ermitteln

  7. Ggf. Payload Type für den XCC korrigieren (Parameter XccDtmfPayloadType)

Beispiel zum Vorgehen

Die Situation:

  • Ausgehender Ruf (Outbound Call) eines AnyDevice

  • DTMF wird vom AnyDevice gesendet

  • DTMF Payload Type ist zu prüfen

Das Vorgehen:

  1. Aushandlung des DTMF Payload Type im SDP-Header:

    In diesem Fall ist der SDP-Header aus der SIP-Nachricht 200 OK des ersten Call Leg zu analysieren (Seite des AnyDevice). Es wurde hier ein Payload Type (Media Format) von 98 ausgehandelt, der Standardwert des XCC.

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  2. RTP-Events der DTMF-Signale ermitteln:

    Über eine Filterregel in Wireshark werden die vom AnyDevice gesendeten DTMF-Signale gelistet.

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  3. Payload Type der RTP-Events ermitteln:

    Eines der oben gefilterten RTP-Events auswählen und im darunter liegenden Bereich den Payload Type auslesen. Auch hier ist der Payload Type 98 und somit korrekt übermittelt.

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  4. Stimmen die beiden ermittelten Typen nicht überein, kann dies über den Parameter XccDtmfPayloadType in den Erweiterte Einstellungen des SIP Gateways korrigiert werden. Dazu wird der in Schritt 1 ermittelte Payload Type der PBX per XccDtmfPayloadType an den XCC weitergegeben und dort korrigiert.

Informationen aus dem XCC Gateway Log

Aus dem Logfile des XCC Gateways können zum Beispiel folgende Informationen entnommen werden:

  • Status der AnyDevice Leitungen.

  • Erstellen von Netzwerktraces mit Hilfe von Npcap.

  • Status des XCC Gateways.

Aktivieren des Loggings

Für eine Fehleranalyse werden immer die Entsprechenden Logfiles benötigt. Ein wesentlicher Vorteil ist die Netzwerkkommunikation lesen zu können. Für den Mitschnitt des Netzwerktraffics auf der Netzwerkkarte wird der Npcap-Treiber benötigt. Dieser ist im Installationsverzeichnis des XPhone Connect Servers unter Tools zu finden.

Das entsprechende Logging kann über die Administration im XPhone Connect Server gestartet werden. Unter Systemeinstellungen > Logging > Telefonie-Gateways können die entsprechenden Log-Levels gesetzt werden.

  1. xccts9

  2. xccts10

  3. xccts11

Sobald die Einstellungen zum Log-Level gespeichert wurden, werden die Logfiles in den angegebenen Dateipfad geschrieben.

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